SharePoint WebDAV

Dec 7, 2011 at 2:13 PM

I am using WebDAV in conjunction with SharePoint portal version 12.0.0.6524.

I also testing using WebDAV via the built-in provider in IIS on Windows Server 2008.

The thing that I found is that GetFile or GetFileSystemObject for a file does not work with SharePoint.

I debugged the problem and SharpBox is issuing a PROPFIND with a Depth=1.  That works fine when using IIS but not SharePoint which returns a 404.

FWIW, if I change the Depth to 0 in Fiddler and reissue the request then it works.

My plan is to work around the issue by always walking from the folder to file.

Just an FYI in case someone else encounters this.

Jan 4, 2013 at 11:20 AM
Edited Jan 4, 2013 at 12:21 PM

I have the same issue by using lighttpd WebDAV server.

I've opened an issue: http://sharpbox.codeplex.com/workitem/19136

Feb 2, 2013 at 5:58 PM
Some of my users (of AJC Sync) are interested in sync with Sharepoint files. How are you getting on with this? Do you have any pointers to get me started with using Sharpbox with Sharepoint?
Feb 2, 2013 at 8:24 PM
<div> <blockquote style="margin:0px 0px 0px 0.8ex; padding-left:1ex; border-left-color:rgb(204,204,204); border-left-width:1px; border-left-style:solid"> <div> <div> <p>It has been a very long time since I looked at this. What I recall is that I used WebDAV. </p> <p>FWIW, I think that the SharpBox project is largely dead. It seems to me that there is no longer any development activity on this project.</p> </div> </div> </blockquote> </div> <br>