This project is read-only.

BoxDotNet returns NULL on GetRoot

Nov 23, 2011 at 7:44 PM

When using BoxDotNet, I can get authorized, but calling GetRoot always returns NULL. I can GetFolder("/Public Folder") and that works. (I have a folder called "Public Folder") But it does me no good, because I don't know the names of the folders before hand. Any help?

Nov 23, 2011 at 8:34 PM

Eh, I should put this in the issue tracker, going to do that...

Nov 27, 2011 at 1:13 AM

I had a similar issue, I believe the problem is in the BoxNetConfiguration, the url is set to https://www.box.net/dav if you change it to https://www/box.com/dav then the code should start working.  I hope this helps.

Jon

Nov 27, 2011 at 8:31 AM
Hi,

oh om thanks. So please attach it to the issues section, we will fix it in the next service release.

Dirk

Sent from my iPad

On 27.11.2011, at 02:13, JonnyWalker81 <notifications@codeplex.com> wrote:

From: JonnyWalker81

I had a similar issue, I believe the problem is in the BoxNetConfiguration, the url is set to https://www.box.net/dav if you change it to https://www/box.com/dav then the code should start working. I hope this helps.

Jon

Jun 2, 2013 at 7:31 PM
the problem is in the BoxNetConfiguration, i have changed "https://www.box.net/dav" with "https://www/box.com/dav" and now work good for upload and download only in the root

but now have 2 problem:
  • a error when change directory (response is the file not exits)
  • when delete file the operation succeeds but the file is not deleted
someone found the same error?

Salvio
Jun 25, 2013 at 12:28 PM
Where can i change the BoxNetConfiguration? Can you please help?
Jun 25, 2013 at 12:28 PM
Where can i change the BoxNetConfiguration? Can you please help?
Aug 8, 2013 at 2:02 AM
The proper URL is https://dav.box.com/dav See the official site at https://support.box.com/entries/20359428-Does-Box-support-WebDAV

To override the setting:
var config = BoxNetConfiguration.GetBoxNetConfiguration();
config.ServiceLocator = new Uri("https://dav.box.com/dav");