This project is read-only.

Funny Characters in Folder and File Names

Dec 23, 2010 at 8:56 AM

Hi all, and thanks to all those involved in a great project.

Could someone more knowledgeable than me post a quick summary of the state of play regarding funny characters in folder and file names.  I'm using the latest source for Windows Phone 7, and I'm having troubles with folder names containing bracket/parenthesis charcters: ) and ( .

Is this a known issue?  Are there other issues with funny characters? (I note a past discussion about space characters, an issue that seems to have been resolved now)  Or am I just doing something stupid?

Thanks

Dec 23, 2010 at 9:17 AM
Hi,
Jay fixed an issue with brackets a couple days ago. Check out this checkin: http://sharpbox.codeplex.com/SourceControl/changeset/changes/65434
If you have this version of the trunk or higher please be so kind and send us your filename. This fixe will be part of 1.0.3 which will be available in the end of this year!
Regards
Dirk


2010/12/23 jrc14 <notifications@codeplex.com>

From: jrc14

Hi all, and thanks to all those involved in a great project.

Could someone more knowledgeable than me post a quick summary of the state of play regarding funny characters in folder and file names. I'm using the latest source for Windows Phone 7, and I'm having troubles with folder names containing bracket/parenthesis charcters: ) and ( .

Is this a known issue? Are there other issues with funny characters? (I note a past discussion about space characters, an issue that seems to have been resolved now) Or am I just doing something stupid?

Thanks

Read the full discussion online.

To add a post to this discussion, reply to this email (sharpbox@discussions.codeplex.com)

To start a new discussion for this project, email sharpbox@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com


Dec 27, 2010 at 4:24 PM

Thanks - I can confirm that the fixed version works for me.

Dec 28, 2010 at 12:22 PM
Hi,
cool, so are you fine with SharpBox 1.0.3?
Regards
Dirk


2010/12/27 jrc14 <notifications@codeplex.com>

From: jrc14

Thanks - I can confirm that the fixed version works for me.

Read the full discussion online.

To add a post to this discussion, reply to this email (sharpbox@discussions.codeplex.com)

To start a new discussion for this project, email sharpbox@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com


Jan 1, 2011 at 4:23 PM

Hi Dirk/all,

Thanks again ... and another query.  Thouugh 1.0.3 is working OK for me for path names containing ) and ( characters, it is not working well for path names containing single-quote characters (').  Can anyone else confirm this behaviour, and/or offer a fix?

Thanks,

Jim

Jan 2, 2011 at 11:41 AM
Hi,

can you send use the path which are you using? I will try it out to fix the bug.

Regards
Dirk

On Jan 1, 2011, at 5:23 PM, jrc14 wrote:

From: jrc14

Hi Dirk/all,

Thanks again ... and another query. Thouugh 1.0.3 is working OK for me for path names containing ) and ( characters, it is not working well for path names containing single-quote characters ('). Can anyone else confirm this behaviour, and/or offer a fix?

Thanks,

Jim


Jan 2, 2011 at 8:01 PM
Hi Dirk,

With my build, at least, the bug is easy to reproduce. I can create a test file called "test.txt" in the root folder of my DropBox, and the file will download successfully using your sample code. Then if I rename this file to"te'st.txt", the download fails (a WebException gets thrown somewhere).

Any help would be much appreciated.

Thanks,

Jim

On 02/01/2011 11:42, dei79 wrote:

From: dei79

Hi,

can you send use the path which are you using? I will try it out to fix the bug.

Regards
Dirk

On Jan 1, 2011, at 5:23 PM, jrc14 wrote:

From: jrc14

Hi Dirk/all,

Thanks again ... and another query. Thouugh 1.0.3 is working OK for me for path names containing ) and ( characters, it is not working well for path names containing single-quote characters ('). Can anyone else confirm this behaviour, and/or offer a fix?

Thanks,

Jim


Jan 3, 2011 at 2:10 PM
Hi,
please send me your code snipplet. I used my lunchbreak to figure out the issues but everything works fine :-(
Thanks a lot
Dirk


2011/1/2 jrc14 <notifications@codeplex.com>

From: jrc14

Hi Dirk,

With my build, at least, the bug is easy to reproduce. I can create a test file called "test.txt" in the root folder of my DropBox, and the file will download successfully using your sample code. Then if I rename this file to"te'st.txt", the download fails (a WebException gets thrown somewhere).

Any help would be much appreciated.

Thanks,

Jim

On 02/01/2011 11:42, dei79 wrote:

From: dei79

Hi,

can you send use the path which are you using? I will try it out to fix the bug.

Regards
Dirk

On Jan 1, 2011, at 5:23 PM, jrc14 wrote:

From: jrc14

Hi Dirk/all,

Thanks again ... and another query. Thouugh 1.0.3 is working OK for me for path names containing ) and ( characters, it is not working well for path names containing single-quote characters ('). Can anyone else confirm this behaviour, and/or offer a fix?

Thanks,

Jim


Read the full discussion online.

To add a post to this discussion, reply to this email (sharpbox@discussions.codeplex.com)

To start a new discussion for this project, email sharpbox@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com


Jan 4, 2011 at 7:38 AM
Edited Jan 4, 2011 at 7:38 AM

Sorry, my bad.  ' characters in file names work fine (I was, by mistake, using a build from just before the fix you put in on 30th Dec, in the 1.03 release).  Sorry for the confusion, and sorry for wasting your time.

Jan 4, 2011 at 7:55 AM
Hi,

oh that's cool! So let me know if you need any help.

Dirk

Sent from my iPhone

On 04.01.2011, at 08:38, jrc14 <notifications@codeplex.com> wrote:

From: jrc14

Sorry, my bad. ' marks in file names work fine (I was, by mistake, using a build from just before the fix you put in on 30th Dec, in the 1.03 release). Sorry for the confusion, and sorry for wasting your time.